Skip to content Skip to sidebar Skip to footer

Local Iis Unable To Connect Local Database

I am using a db from (localdb)\V11.0 server and able to connect successfully when using IIS express from VS2013, but when deployed in LocalIIS, it gives me an error below - A net

Solution 1:

To get local db running with IIS on my machine, I followed the guidance in this msdn blog

The solution that worked best for me was to configure IIS application pools to run as my windows user.

This is done via the IIS interface. In the "Application Pools" section, right click on one (or more) and choose "Advanced Settings". Choose "Identity" and "Custom" then enter your username and password.

Solution 2:

You can check if Application Pool / Local System has an account to access the database. There is also an option to user impersonate user https://support.microsoft.com/en-us/kb/306158 example:

<identityimpersonate="true"userName="accountname"password="password" />

Post a Comment for "Local Iis Unable To Connect Local Database"